Applications Failing to Load with "Something Went Wrong" Error

Incident Report for Alloy

Resolved

The issue that caused some applications to fail to load and display a “Something Went Wrong” error has been fully resolved. Thank you for your patience during our investigation.
Posted Jul 24, 2025 - 12:32 EDT

Monitoring

We’ve identified an issue causing some applications to fail to load with a ‘Something Went Wrong’ error. A fix has been deployed, and our engineering team is actively monitoring to ensure stability.
Posted Jul 24, 2025 - 10:25 EDT
This incident affected: Customer Dashboard.