Degraded Dashboard Performance

Incident Report for Alloy

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 15:09 EDT

Update

We have identified and resolved the issue. Dashboard analytics page is operational.
Posted Jun 11, 2025 - 15:09 EDT

Update

We are continuing to investigate this issue.
Posted Jun 11, 2025 - 14:37 EDT

Investigating

We have received reports of performance degradation with the Alloy dashboard. We are investigating this as a matter of priority.
Posted Jun 11, 2025 - 14:37 EDT
This incident affected: Customer Dashboard.