Production API Error Elevation
Incident Report for Alloy
Resolved
From 12:52 EDT until 1:57 EDT, urgent maintenance running on our production database caused a significant increase in processing time for our dashboard and api actions. From 1:58 EDT until 2:15 EDT, queries to our api were unresponsive. During this time, we worked to reduce the load on our database and restore service back to normal. We are making adjustments to our internal processes to ensure that we have no reoccurrences of similar issues.
Posted Sep 30, 2022 - 14:44 EDT
Monitoring
We've applied the fix and are monitoring.
Posted Sep 30, 2022 - 14:27 EDT
Update
Some clients would likely be experiencing hight latency when sending requests. We've identified the problem and are working on a fix.
Posted Sep 30, 2022 - 14:14 EDT
Investigating
Our API integration tests have encountered an increase in errors. We are currently investigating. Stay tuned for updates.
Posted Sep 30, 2022 - 12:53 EDT
This incident affected: Production API, Customer Dashboard, and Sandbox API.