CloudFlare incident causing increased errors for data services

Incident Report for Alloy

Resolved

Alloy is observing error rates have decreased across all impacted services as of 9:36 AM ET.

CloudFlare has confirmed a fix has been implemented as of 9:42 AM ET. More information about the CloudFlare outage can be found here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 10:08 EST

Update

Our monitoring has detected that the services Middesk, Iovation, Iovation Registration, and Zenwork Compliancely TIN Match are seeing full downtime due to a CloudFlare outage. We have reached out to the services for more information, and we are awaiting resolution from CloudFlare. We will periodically update the status page as we learn more.

More information about the CloudFlare outage can be found here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 08:52 EST

Investigating

A widespread Cloudflare outage is impacting multiple services, including Iovation and Middesk. We are monitoring the situation and investigating possible mitigation.
Posted Nov 18, 2025 - 08:37 EST
This incident affected: Production API.